- Posts: 6
- Thank you received: 0
Ошибки после удаления Slogin
- Offline
- New Member
Less
More
9 years 9 months ago - 9 years 9 months ago #6335
by
Ошибки после удаления Slogin was created by
Добрый день!
После удаления SLOGIN на Joomla 3.6.4 при попытке удаления какого-либо пользователя из менеджера пользователей получаю ошибку
Ошибка возникает из-за обращения к несуществующей таблице #__slogin_users, которая удалается вместе с компонентом. Что остается в системе после удаления и как это исправить? Исправление базы стандартными средствами Joomla не помогло.
Ошибку можно воспроизвести при установке компонента v 2.5 на чистую версию Joomla 3.6.4. Достаточно стандартным способом зарегистрировать пользователя, затем удалить компонент (пакет также сразу не удалится), после чего при удалении пользователя вы получите ошибку. Снимки экрана ниже.
После удаления SLOGIN на Joomla 3.6.4 при попытке удаления какого-либо пользователя из менеджера пользователей получаю ошибку
Code:
Table 'XXXX.#__slogin_users' doesn't exist SQL=DELETE FROM `#__slogin_users` WHERE `user_id` = 1234
Ошибку можно воспроизвести при установке компонента v 2.5 на чистую версию Joomla 3.6.4. Достаточно стандартным способом зарегистрировать пользователя, затем удалить компонент (пакет также сразу не удалится), после чего при удалении пользователя вы получите ошибку. Снимки экрана ниже.
Last edit: 9 years 9 months ago by .
Please Log in to join the conversation.
- Offline
- Admin
Less
More
- Posts: 2227
- Thank you received: 188
9 years 9 months ago #6337
by
Replied by on topic Ошибки после удаления Slogin
Пожалуйста создавайте новые темы для вопросов, не связанных с общей темой.
В данном случае вероятно вы удалили не пакет, а компонент при этом у вас остался весь набор плагинов. В прошлом выпуске мы делали исправления на эту тему, но по всей видимости не до конца.
Для корректной работы сайта отключите плагин: Social Login Auth и Social Login s.mail.ru/3n35/LZ1a6Tmos
А лучше все таки пользоваться удалением пакета, так как расширение включает в себя почти 2 десятка расширений и если вы не планируете его использовать, то лучше удалить все.
В данном случае вероятно вы удалили не пакет, а компонент при этом у вас остался весь набор плагинов. В прошлом выпуске мы делали исправления на эту тему, но по всей видимости не до конца.
Для корректной работы сайта отключите плагин: Social Login Auth и Social Login s.mail.ru/3n35/LZ1a6Tmos
А лучше все таки пользоваться удалением пакета, так как расширение включает в себя почти 2 десятка расширений и если вы не планируете его использовать, то лучше удалить все.
The following user(s) said Thank You:
Please Log in to join the conversation.
- Offline
- New Member
Less
More
- Posts: 6
- Thank you received: 0
9 years 9 months ago #6339
by
Replied by on topic Ошибки после удаления Slogin
Удалял изначально пакет. Причем, сразу все так и не удалилось. Потом компонент, а затем пришлось удалять все остальное. Пробовал дважды. Затем устанавливал заново и снова пытался удалить правильно. Безрезультатно. В данным момент подымаю резервную копию. Готов сделать снимок экрана/видео.
Please Log in to join the conversation.
- Offline
- Admin
Less
More
- Posts: 2227
- Thank you received: 188
9 years 9 months ago #6340
by
Replied by on topic Ошибки после удаления Slogin
напишите на sale@joomline.ru
Укажите доступы к админ панели мы проверим что у вас не так.
Укажите доступы к админ панели мы проверим что у вас не так.
The following user(s) said Thank You:
Please Log in to join the conversation.
- Offline
- New Member
Less
More
- Posts: 6
- Thank you received: 0
9 years 9 months ago - 9 years 9 months ago #6341
by
Replied by on topic Ошибки после удаления Slogin
Last edit: 9 years 9 months ago by .
Please Log in to join the conversation.
- Offline
- New Member
Less
More
- Posts: 6
- Thank you received: 0
9 years 9 months ago #6344
by
Replied by on topic Ошибки после удаления Slogin
После удаления плагинов все стало на свои места. К сожалению, плагины не удаляются автоматически при удалении пакета и компонента. Причем можно не найти их, если вводить в поиске "slogin". Плагины названы без сокращения - Social Login). Об этом было сказано
выше
. Вопрос закрыт.
Please Log in to join the conversation.
- Offline
- Admin
Less
More
- Posts: 2227
- Thank you received: 188
9 years 9 months ago #6345
by
Replied by on topic Ошибки после удаления Slogin
мы уже выяснили причину почему они не удаляются... в следующем релизе уже будет пакет без проблем удаляться спасибо за помощь.
The following user(s) said Thank You:
Please Log in to join the conversation.
- Offline
- New Member
Less
More
- Posts: 4
- Thank you received: 0
8 years 7 months ago #6966
by
Replied by on topic Ошибки после удаления Slogin
Здравствуйте. У меня аналогичная проблема, только сразу после установки. Slogin я планирую использовать в связке с jcomments. Версия joomla 3.6.0 . При открытии плагина "Plugin profile Slogin" в менджере плагина мне выдается окно тайтл (больше нигде я данную ошибку пока не наблюдаю) которого содержит следующую ошибку
<title>Ошибка: 1146 Table '2gym.#__fields' doesn't exist SQL=SELECT id as value, title as text
FROM #__fields
WHERE context = 'com_users.user' AND type IN('text', 'media', 'url')</title>
У себя в бд я нашел таблицу 'префикс_users' в которой хранятся все данные юзеров. Скажите как быть, что делать в данной ситуации? Нужно создать вручную данную таблицу 'com_users.user' и почему она не создалась автоматом? Исправить БД в админпанели не помогло решить проблему.
Если нужно создать в ручную не могли бы вы написать запрос к базе который добавить недостающие поля, т.к. не разбираюсь в бд. Спасибо.
<title>Ошибка: 1146 Table '2gym.#__fields' doesn't exist SQL=SELECT id as value, title as text
FROM #__fields
WHERE context = 'com_users.user' AND type IN('text', 'media', 'url')</title>
У себя в бд я нашел таблицу 'префикс_users' в которой хранятся все данные юзеров. Скажите как быть, что делать в данной ситуации? Нужно создать вручную данную таблицу 'com_users.user' и почему она не создалась автоматом? Исправить БД в админпанели не помогло решить проблему.
Если нужно создать в ручную не могли бы вы написать запрос к базе который добавить недостающие поля, т.к. не разбираюсь в бд. Спасибо.
Please Log in to join the conversation.
- Offline
- Admin
Less
More
- Posts: 2227
- Thank you received: 188
8 years 7 months ago #6968
by
Replied by on topic Ошибки после удаления Slogin
Гхмм... вероятно ошибка из-за внедрения в Slogin поддержки кастомных полей, так как эта функция требует Joomla 3.7 и выше вылетает ошибка.
Please Log in to join the conversation.
- Offline
- New Member
Less
More
- Posts: 4
- Thank you received: 0
8 years 7 months ago - 8 years 7 months ago #6969
by
Replied by on topic Ошибки после удаления Slogin
насколько критична эта ошибка ? может имеет смысл поставить slogin более поздней версии ?
Last edit: 8 years 7 months ago by .
Please Log in to join the conversation.
- Offline
- Admin
Less
More
- Posts: 2227
- Thank you received: 188
8 years 7 months ago #6975
by
Replied by on topic Ошибки после удаления Slogin
Можете поставить ниже версии 2.6 ошибка в целом то не критичная.
Please Log in to join the conversation.
- Offline
- Admin
Less
More
- Posts: 2227
- Thank you received: 188
8 years 7 months ago #6976
by
Replied by on topic Ошибки после удаления Slogin
Добавил в список задач
Please Log in to join the conversation.
Time to create page: 0.239 seconds